Error message when CallHome receives a list exceeding 320 IP addresses
Error message appears in sever log files when CallHome recieves a list of more than 320 IP addresses.
- Problem
The above error message may appear in the server log files. The IP addresses list will exceed the value of 320 in Remote Control Sever Version 10.1 Fixpack 1 or 256 in earlier versions.[ERROR] - CallHome received from Computer Name [computer name] Key [key] has list of IP addresses that exceeds 320. Value is truncated.
- Cause
-
When a target reports the status to the server, it presents the server with a list of IP addresses. This list may become very long depending on the target condition and when the length of such a list becomes too long, the above error message is logged. The reason of getting such long list of IP addresses should be investigated.
- Solution 1
- The preferred solution is to set the property DisableIPv6 to yes in the Remote Control Target Configuration. You can use the target configuration wizard to perform this task.
- Solution 2
-
This alternate solution should be considered only when it is not possible to set the DisableIPv6 property. This solution is applicable only in Remote Control Sever Version 10.1 Fixpack 1 or higher. With this solution you can increase the IP addresses list length to a value of your choice. The following example shows how to increase the length value to 512 for MSSQL database. Increase the column size in the database with the following commands:
ALTER TABLE ASSET.ASSET ALTER COLUMN IP_ADDRESSES VARCHAR(512);
ALTER TABLE COMMON.LIVEPOINTS ALTER COLUMN IP_ADDRESSES VARCHAR(512);
Next update the server configuration as follows:- In Admin > Edit Properties Files, select Common Properties from the drop down.
- At the bottom of the page, change the value of the property target.ip.length.limit to 512.
- Click Submit and Admin > Reset Application.