IRX file is too large to analyze
Symptom
AppScan on Cloud is unable to scan a generated IRX file due to size.
Cause
The most common reason an IRX file is particularly large is the inclusion of third-party libraries and/or code in a scan. Third-party dependencies should be available for the scan, but we do not recommend analyzing them directly.
Resolution
When you generate an IRX file in AppScan on Cloud, ASoC also creates an archive of logs named <scan name>_logs.zip. Review the scan.manifest file within that archive to see what files are being scanned. If there are numerous third-party files listed in non-Open Source language sections of the scan.manifest file, and thus being scanned, use an appscan-config.xml file to limit the scope of the scan to just your files and code. See Configuring IRX file generation with the CLI for details about creating an appscan-config.xml file.
If your scan does not contain third-party artifacts, contact HCL Customer Support for additional assistance.