Troubleshooting

Use the information described here to troubleshoot problems.

Problem 1: When the automation plan engines are installed on one or more DSA servers

When the automation plan engines are installed on one or more DSA servers in your environment, each step of the automation plan execution is created several times instead of once. The number of times each step is created is equal to the number of DSA servers, with the automation plan engine installed, present in your environment.

Cause:

In a DSA environment, you can install the Server Automation components on both the servers (primary and secondary), but you must ensure that only one instance is active at any given time. Otherwise, multiple actions are created for each step in the plan, and both plan engine instances process the same plan.

Solution:

To disable the plan engine on a DSA server, perform these steps:

  1. Immediately after installing the plan engine, go to <BES Root Dir>\Applications\Config and rename the PlanEngine.xml file into PlanEngine.xml.stop.
  2. To ensure that it is stopped, check the <BES Root Dir>\Applications\Logs\pe_console.log file. When stopped, no new message is posted on this log file.
Important: In the event of a primary root server failure:
  • On the secondary DSA server, rename the PlanEngine.xml.stop file back to PlanEngine.xml .
  • On the primary server, disable the plan engine instance by adding the .stop extension to the PlanEngine.xml file).

Problem 2: Delay in starting the scheduled plans

In a DSA enviroment setup, there can be a delay in starting the scheduled plans.

Cause:

In a DSA environment, the plan engine checks if any plan engine instances exist on the secondary server, regardless of an actual instance running or not. This check is done while the current plan is being processed. This tries to stop the current running instance, which delays the processing of the scheduled plans.

Solution:
Step 1:
Keep only one instance up and running and disable/uninstall the plan engine on the other (secondary) DSA servers. Perform these steps to disable the plan engine:
  1. Immediately after installing the plan engine, go to <BES Root Dir>\Applications\Config and rename the PlanEngine.xml file into PlanEngine.xml.stop.
  2. To ensure that the plan engine is stopped, check the <BES Root Dir>\Applications\Logs\pe_console.log file. When stopped, no new message is posted on this log file.
Step 2:
Perform these steps to use the DSA flag to disable the DSA checks:
  1. Go to <BES Root Dir>\Applications\PlanEngine\bin\planengine.bat
  2. Set VM_ARGS=%VM_ARGS% -Denable.dsa=0 (by default its set to 0 since 9.5.65)
Important: In the event of a primary root server failure:
  • On the secondary DSA server, rename the PlanEngine.xml.stop file back to PlanEngine.xml .
  • On the primary server, disable the plan engine instance by adding the .stop extension to the PlanEngine.xml file).
Note:
  • This solution works only if the plan engine version is 9.5.64 or later.
  • If you diable the DSA flag but keep more than one instance of Plan engine up and running, then it results in Problem 1: When the automation plan engines are installed on one or more DSA servers.
  • If the Plan engine version is in between 9.5.53 and 9.5.63, there is no option to disable the DSA checks. In this case, you need to upgrade to the latest version to use the above solution.