IRX 上傳失敗,因為加密不符

症狀

當您嘗試上傳 IRX 檔案進行掃描時,看到此錯誤:

Error: The .irx file was encrypted for use in a different service.

原因

IRX 檔案已針對您目前的服務實例,使用錯誤的公開金鑰進行加密。

每個 AppScan 服務實例(AppScan on CloudAppScan 360° 或私有實例)均使用唯一的加密金鑰組:
  • 公開金鑰:由服務分散以加密 IRX 檔案。
  • 私密金鑰:由服務保留以解密並處理上傳作業。

公開和私密金鑰會以與數學相關且獨特的方式識別使用者;由其中一個金鑰加密的資料,只能由配對中的另一個金鑰解密。因此,只有具有相符私密金鑰的服務,才能分析為該服務使用公開金鑰加密的 IRX 檔案。嘗試上傳針對不同服務加密的檔案會導致上述錯誤。

解決方案

如果要解決這個問題,請依照下列步驟操作:
  1. 檢查您的服務 URL。
    1. 開啟 server.apsettings 檔。
      • AppScan on CloudAppScan 360° 和私有實例: SAClientUtil\config\server.apsettings
      • AppScan Go! 和外掛程式: <user_home>\.appscan\<SAClientUtil>\config\server.apsettings
    2. 確認 service_url 與您嘗試上傳 IRX 檔案的服務完全相符。

      例如,如果您要上傳至 ASoCservice_url 應該是 https://cloud.appscan.comhttps://eu.cloud.appscan.com。如果您要上傳至 AppScan 360°service_url 應該符合安裝時指定的位置。如果您使用的是私有實例,service_url 則應與私有實例 URL 相符。

  2. 更新您的公開金鑰。
    • SAClientUtil 資料夾中,為您所選的服務擷取正確的 rsa.pub 金鑰。執行:
      appscan get_pubkey
  3. 重新產生 IRX 並再次嘗試上傳。