IRX ファイルが大きすぎて分析できない
症状
AppScan on Cloud は、サイズが原因で、生成された IRX ファイルをスキャンできません。
原因
IRX ファイルが特に大きくなる最も一般的な理由は、サードパーティーのライブラリーやコードがスキャンに含まれているためです。サードパーティーの依存関係はスキャンに使用できる必要がありますが、直接分析することを推奨しません。
解決方法
AppScan on Cloud で IRX ファイルを生成すると、ASoC で <scan name>_logs.zip という名前のログのアーカイブも作成されます。そのアーカイブ内の scan.manifest ファイルで、スキャンされているファイルを確認します。scan.manifest ファイルの非オープン・ソース言語セクションで多数のサードパーティー・ファイルがリストされている場合、それらのファイルがスキャン対象となっているため、appscan-config.xml ファイルを使用して、スキャン範囲を使用するファイルとコードのみに限定します。appscan-config.xml ファイルの作成について詳しくは、「CLI を使用した IRX ファイル生成の構成」を参照してください。
注: オープン・ソース言語の下にリストされているサードパーティー・ライブラリーは通常のライブラリーであり、IRX のサイズには影響を与えません。
スキャンにサードパーティーの成果物が含まれていない場合は、HCL お客様サポートに連絡して追加の支援を求めてください。