HCL Informix® OLE DB Provider not registered
When you attempt to connect to the HCL Informix® data source, a message says that Informix® OLE DB Provider is not registered.
Informix® OLE DB Provider is not visible in the enumeration (for example, in the Initialize Data Source dialog box in the Microsoft™ OLE DB query demonstration).
Possible cause
Informix® OLE DB Provider is not installed.
Resolution
Informix® OLE DB Provider is distributed with Informix® Connect and the Informix® Client Software Development Kit, Version 2.3 and later; however, it is not installed unless you choose the Custom installation option and explicitly select Informix® OLE DB Provider.
During installation, the Informix® OLE DB Provider DLL is copied to INFORMIXDIR\bin. If Informix® OLE DB Provider is copied to your computer but still is not visible in the enumeration, make sure the DLL is registered on the local computer.
- Go to INFORMIXDIR\bin.
- Run the regsvr32 command on the DLL (ifxoledbc.dll).