Unable to record tests on a Windows Server system
When you install HCL DevOps Test UI (Test UI) on a Windows Server system and try to record a test for a Windows application, the recording fails with an error.
Cause
The test generation fails because of a privilege issue on the Windows Server system.
Resolution
- Perform the following steps to restart the UI Test Agent as an administrator
user:
-
Start the command prompt as an administrator user by right-clicking it and selecting the Run as administrator option.
-
Navigate to the UITestAgent directory by running the following command:
cd "C:\Program Files\HCL\DevOpsTest\UITestAgent\" -
Run UITestAgentStop.bat to stop the agent and wait for the UI Test Agent icon to disappear from the system tray.
-
Run UITestAgentStart.bat to restart the agent and wait for the UI Test Agent icon to display in the system tray.
You can also verify the agent status by opening the following URL: http://localhost:7082/wd/hub/status.The following message is displayed if the agent is running:
{"value":{"ready":true,"message":"The server is ready to accept new connections","build":{"version":"2.19.0"}}}
-
- In the Start menu, right-click DevOps Test UI and select Run as administrator.
- Record a test for a Windows application.