安全掃描失敗,出現 Application with id x does not exist
錯誤
症狀
由於下列錯誤,使用 Jenkins 或 IDE 外掛程式或指令行介面 (CLI) 的掃描執行失敗:
Application with id x does not exist
Failed to run the security scan: Problems occurred submitting the IRX file to the
analysis service.
原因
先前,AppScan on Cloud 會根據 app_id
來建立應用程式關聯。最近的更新將此關聯從 app_id
變更為 guid
。在大多數的情況下,ASoC 服務會提示您根據此更新來重新關聯應用程式。針對 Jenkins 以及 IDE 外掛程式和 CLI,您必須採取額外的步驟。
解決
針對 Jenkins 外掛程式,請根據將安全分析新增至 Jenkins 自動化伺服器上的指示來重新儲存 Jenkins 外掛程式配置,然後重試掃描。
針對 IDE 外掛程式,請重新選取相同的應用程式來掃描,然後按一下「確定」。
對於 CLI 而言,新的 guid
會取代 app_id
。guid
是一個唯一的 32 字元 ID。例如 33c3281a-6d7c-e711-b334-002590731623
。請使用 appscan list_apps
指令判定各個應用程式的 guid
,然後在 Script 中或指令行上的 queue_analysis
指令中,以 guid 取代 app_id
。