Application with id x does not exist
エラーでセキュリティー・スキャンが失敗する
症状
Jenkins または IDE プラグインもしくはコマンド行インターフェース (CLI) を使用したスキャンの実行が次のエラーで失敗する。
Application with id x does not exist
Failed to run the security scan: Problems occurred submitting the IRX file to the
analysis service.
原因
以前は、AppScan on Cloud は app_id
に基づいてアプリケーションを関連付けていました。最近の更新で、この関連付けが app_id
から guid
に変更されました。ほとんどの場合、ASoC サービスはこの更新に基づいてアプリケーションを再度関連付けるよう促します。Jenkins および IDE プラグインと CLI の場合、追加の手順を踏む必要があります。
解決
Jenkins プラグインの場合は、Jenkins 自動化サーバーへのセキュリティー分析の追加の指示に従って Jenkins プラグイン構成を再保存し、スキャンを再試行してください。
IDE プラグインの場合は、プロンプトが表示されたら、スキャンする同じアプリケーションを選択し、「OK」をクリックします。
CLI の場合は、新規の guid
が app_id
に取って代わります。guid
は、固有の 32 文字の ID です。例えば、33c3281a-6d7c-e711-b334-002590731623
などです。appscan list_apps
コマンドを使用して、各アプリケーションの guid
を判別し、スクリプトまたはコマンド行の queue_analysis
コマンドで app_id
をその guid に置き換えます。