HCL AppScan 360° における既知の問題

リリースの既知の問題と、該当する場合の回避策。

AppScan 360° バージョン 1.5.0 の既知の問題

AppScan 360° バージョン 1.4.0 の既知の問題

  • SAST スキャン以下の「AppScan GitHub アプリケーションをインストール」ボタンまたはリンクは、Presence を選択した後にのみ機能します。
  • ドメイン管理において、資産グループ・フィルター「All」が期待どおりに機能していません。
  • スケジュールされたスキャンでは、ESM ログが記録されていません。
  • AppScan Go! の自動更新が機能していません。詳しくは、「AppScan Go! の自動更新に失敗しました」を参照してください。

AppScan 360° バージョン 1.3.0 の既知の問題

  • スキャンが 1~2 分以内に失敗し、「Error: An unknown error occurred (不明なエラーが発生しました)」と表示される場合は、次のどちらかです。
    • サーバーがダウンしているか到達できない
    • 開始 URL が間違っている
    ログ・ファイルをダウンロードして、問題を確認してください。
    1. AppScan 360° 「スキャン」ページで、「スキャンの管理」 > 「ログのダウンロード」を選択します。
    2. .ZIP ファイルをダウンロードして、コンテンツを抽出します。
    3. ScanLog_<yy>.log を開きます (ここで、yy は 1 から 100 までの数値)。
    4. メッセージ CRWAD0601I - [ServerDown] Cannot connect to host: が表示される場合:
      • ターゲット・サーバーに到達でき、応答があることを確認する
      • 開始 URL が正しいことを確認する
  • スキャンの開始 URL を入力すると、「Unless this is a private network, please verify your domain.Learn more (これがプライベート・ネットワークでない場合は、ドメインを確認してください。詳細)」というエラー・メッセージが表示されることがあります。入力した開始 URL の先頭に空白文字がないことを確認してください。空白文字を削除して、再試行してください。
  • 暗号化されたトラフィック・ファイルはサポートされません。
  • スキャンが複数回実行された場合、ログ・ファイルには同じ名前のファイルが複数存在しています。ログ・ファイルの抽出には、7zip などの自動名前変更機能をサポートするアーカイブ・ユーティリティーを使用してください。

AppScan 360° バージョン 1.2.0 の既知の問題

AppScan Central Platform における既知の問題
  • 一部のインストールでは、規制およびコンプライアンス・レポートが問題なく生成されます。

    問題を解決するには、ascp-mr-tasks-manager で始まるポッドを再起動して、スケジューラーがレポートのデータをリフレッシュするようにしてください。ほとんどの場合レポートは 20 分後に機能し始めますが、場合によっては 24 時間かかることがあります。

  • スキャン結果の処理時に、「フィルター」ダイアログ・ボックスの「クリア」オプションを使用してフィルターをクリアすると、問題がすべて削除されます。
  • フィルタリングされた修正グループのリストのセキュリティー・レポートを生成しようとしても、レポートを生成できない場合があります。
  • スキャンをデプロイしても、スキャンを実行するためのリソースが不足していると、AppScan Central Platform に状態が「実行中」として表示されていてもスキャンが停止して進行しないことがあります。
    K8S クラスターでスキャンのステータスを確認してください。スキャン (sast-job- で名前が始まる) のステータスが「保留中」になっている場合もあります。このような場合は、次のいずれかの操作を行ってください。
    • 他のスキャンが終了し、リソースが解放されるまで待ちます。十分なリソースが使用可能になると、「実行中」/「保留中」のスキャンが続行されます。
    • リソースを追加して、スキャンを再度デプロイします。

AppScan 360° バージョン 1.1.0 の既知の問題

AppScan Central Platform における既知の問題

  • 一部のインストールでは、規制およびコンプライアンス・レポートが問題なく生成されます。

AppScan 360° 静的分析 における既知の問題

  • AppScan 360° バージョン 1.0.0 からのアップグレードに失敗します。

    エラー:

    RabbitMQ のバージョンのアップグレードに失敗したため、アップグレード中にデプロイメントが失敗しました。
    • Feature flags: classic_mirrored_queue_version: required feature flag not enabled! It must be enabled before upgrading RabbitMQ.
    • Failed to initialize feature flags registry: {disabled_required_feature_flag, classic_mirrored_queue_version}
    根本原因

    AppScan 360° 静的分析 のバージョン 1.0.0 では RabbitMQ のバージョン 3.11.10 が使用されていますが、RabbitMQ は後にアップグレードされています。AppScan 360° 静的分析 のバージョン 1.0.0 の既存のデプロイメントが、AppScan 360° 静的分析 バージョン 1.1.0 以降にアップグレードされると、featureflags が有効化されて RabbitMQ のアップグレードが可能になるまでデプロイメントは失敗します。

    解決方法

    アップグレードする前に、RabbitMQ ポッドで、featureflags を手動で有効にします。
    1. アクティブで実行中の RabbitMQ ポッドでシェルを開きます。
    2. rabbitmqctl enable_feature_flag all コマンドを実行します。
    3. AppScan 360° 静的分析デプロイして、アップグレードします。

    または、AppScan 360° 静的分析 バージョン 1.0.0 をアンインストールして、AppScan 360° 静的分析 バージョン1.1.0 の新規インストールを実行します