Security scan fails with Application with id x does not exist
error
Symptom
Running a scan that uses the Jenkins or IDE plugin or command line interface (CLI) fails with this error:
Application with id x does not exist
Failed to run the security scan: Problems occurred submitting the IRX file to the
analysis service.
Cause
Previously, AppScan 360° associated applications based on the app_id
. A recent update changed this
association from app_id
to guid
. For the most part, the AppScan 360° service will prompt you to
reassociate applications based on this update. For the Jenkins and IDE plugins and CLI, you must
take additional steps.
Resolution
For the Jenkins plugin, re-save your Jenkins plugin configuration according to the instructions at Adding security analysis to your Jenkins automation server and try the scan again.
For the IDE plugin, when prompted, re-select the same application to scan and click OK.
For CLI, the new guid
replaces app_id
. The
guid
is a unique 32-character identifier. For example,
33c3281a-6d7c-e711-b334-002590731623
. Using the appscan list_apps
command, determine the
guid
for each app and replace the app_id
with it in the
queue_analysis
command in scripts or on the command line.