トラブルシューティング
こちらに記載の情報を使用して、問題のトラブルシューティングを行ってください。
自動化プラン・エンジンが 1 つ以上の DSA サーバーにインストールされている場合
環境内で 1 つまたは複数の DSA サーバーに自動化プラン・エンジンがインストールされると、自動化プランの実行の各ステップは 1 回ではなく複数回作成されます。各ステップが作成される回数は、環境内にある自動化プラン・エンジンがインストールされている DSA サーバーの数と同じです。
原因:
DSA 環境では、Server Automation コンポーネントを両方のサーバーにインストールできますが、常に 1 つのインスタンスのみアクティブであるようにする必要があります。そうなっていないと、プランのステップごとに複数のアクションが作成されます。両方のプラン・エンジン・インスタンスが同じプランを処理します。
解決方法:
DSA サーバーでプラン・エンジンを無効にするには、以下のステップを実行します。
- インストール後すぐに
<BES Root Dir>\Applications\Configに移動し、PlanEngine.xmlファイルの名前をPlanEngine.xml.stopに変更します。 - 停止していることを確認するには、
<BES Root Dir>\Applications\Logs\pe_console.logファイルを確認してください。ログ・ファイルに新規メッセージは通知されません。
- セカンダリー DSA サーバーで、
PlanEngine.xml.stopファイルの名前をPlanEngine.xmlに戻します。 - ただし、忘れずにプライマリー・サーバーのプラン・エンジン・インスタンスも無効にしてください (プライマリー・サーバーで
.stop拡張をPlanEngine.xmlファイルに追加)。
スケジュールされた計画の開始時の遅延
DSA 環境のセットアップでは、スケジュールされた計画の開始時に遅延が生じる可能性があります。
原因:
DSA 環境では、プラン・エンジンは、実際に実行されているインスタンスに関係なく、セカンダリー・サーバーにプラン・エンジン・インスタンスが存在するかどうかをチェックします。このチェックは、最新計画の処理中に実行されます。これにより、現在実行中のインスタンスが停止され、スケジュールされた計画の処理が遅れます。
- ステップ 1:
- 1 つのインスタンスだけを稼働状態に保ち、もう一方の (セカンダリー) DSA サーバーでプラン・エンジンを無効化/アンインストールします。プラン・エンジンを無効にするには、次の手順を実行します。
- インストール後すぐに <BES Root Dir>\Applications\Config に移動し、PlanEngine.xml ファイルの名前を PlanEngine.xml.stop に変更します。
- プラン・エンジンが停止していることを確認するには、<BES Root Dir>\Applications\Logs\pe_console.log ファイルを確認してください。ログ・ファイルに新規メッセージは通知されません。
- ステップ 2:
- DSA フラグを使用して DSA チェックを使用不可にするには、次の手順を実行します。
- 移動 <BES Root Dir>\Applications\PlanEngine\bin\planengine.bat
- 設定 VM_ARGS=%VM_ARGS% -Denable.dsa=0 (by default its set to 0 since 9.5.65)
- セカンダリー DSA サーバーで、
PlanEngine.xml.stopファイルの名前をPlanEngine.xmlに戻します。 - ただし、忘れずにプライマリー・サーバーのプラン・エンジン・インスタンスも無効にしてください (プライマリー・サーバーで
.stop拡張をPlanEngine.xmlファイルに追加)。
- このソリューションは、プラン・エンジンのバージョンが 9.5.64 以降の場合にのみ機能します。
- DSA フラグを使用不可にしても、プラン・エンジンの複数のインスタンスを稼働状態に保つと、自動化プラン・エンジンが 1 つ以上の DSA サーバーにインストールされている場合 になります。
- プラン・エンジンのバージョンが 9.5.53 ~ 9.5.63 の場合、DSA チェックを使用不可にするオプションはありません。この場合、上記のソリューションを使用するには、最新バージョンにアップグレードする必要があります。
安全なパラメーター Fixlet を使用した自動化計画の作成が失敗します
安全なパラメーター Fixlet 用 SA REST API から自動化計画を作成するために API 要求が送信されると、ActionID が作成されず、不正な要求エラーがスローされます。
原因:
要求が Postman または Swagger から送信されたときにユーザー名、パスワード、パスワードの確認の各フィールドが欠落している場合、SA REST API から自動化計画を作成する現在のワークフローでは、安全なパラメーター Fixlet が解析されません。
解決方法:
- Postman または Swagger から API 要求を送信する場合は、安全なパラメーター Fixlet に必要なフィールド (ユーザー名、パスワード、パスワードの確認) が要求ペイロード内に含まれ、正しくフォーマットされていることを確認します。
- 次の作成: Automation Plan のステップに従います。