Loop creation failure at the Measure stage

When you try to create a loop, the loop creation might fail at the Measure stage consistently, even after multiple retries.

Cause

The .yaml file has failed to upload or apply properly.

Resolution

To resolve this issue, you must perform the following tasks:
  1. Log in to DevOps Loop.
  2. Open DevOps Measure from the switcher.
  3. Navigate to Settings > Integrations.
  4. Check the status of DeployLoops and YAML-ExtConfig plugins, and based on the status, perform one of the following steps:
    • If any of the plugin is disabled, enable the plugin, and then go to step 8 to retry the loop creation.
    • If the YAML-ExtConfig plugin is not listed in the Integrations tab, then contact the technical support team for assistance.

    • If the status of any of the plugins is Failed, then contact the technical support team for assistance.

  5. Navigate to Settings > External Config Pipeline.
  6. Check the status of the <loop_name>.yaml that is uploaded for the loop.
  7. Perform one of the following steps based on the .yaml file status:
    • If the file is Not applied, click Apply, and then go to step 8 to retry the loop creation.
    • If the file status is Failed, contact the technical support team for assistance.
  8. Navigate to DevOps Loop.
  9. On the My Loops page, select the Incomplete tab and click Retry for your failed loop.

    You must retry till the loop creation is successful.