BigFix エージェントのデプロイメント

MDM サーバー分析のパスが正しくないと、MCM デプロイ・エージェントのアクションが停止します。

問題

BigFix インストーラーが MDM サーバーで事前ステージングされていても、BigFix エージェントは展開できません。

  • BigFix Agent の展開中、使用可能パッケージのリストには最新のパッケージが表示されません。
    macOS 用 BES エージェントのパッケージ
  • MDM サーバーで BigFix インストーラーを事前ステージングした後でも、BigFix エージェントをデプロイしようとすると警告が表示されます。

原因

この問題には、いくつかの要因が考えられます。

  • 古くて、今は不要になっている MDM サーバーを誤ってアンインストールしても、ファイルは残るため、(そのサーバー上で行われない) 分析では、アンインストールされた MDM サーバーの存在が誤って検出されることがあります。
  • 不正確なディレクトリーに対する BESAgent Packages Available の分析ポイント - サブディレクトリー (/var/opt/BESUEM/packages/macOS) に代わる (/var/opt/BESUEM/packages)
  • WebUI では古くなった情報がキャッシュされており、直近の分析結果を使用されていません。
  • 複数の MDM サーバーが存在している場合、WebUI は、最新の分析結果ではなく、リスト内の最初のサーバーからパッケージを検索します。

回避策

適切なディレクトリに必要なファイルを配置し、WebUI が最新の BigFix エージェント・パッケージを正しく識別および使用できるようにすることで、上記の問題を解決することができます。そのためには、以下の手順を行います。

  1. 残存ファイルのクリーンアップ:

    古い未使用の MDM サーバー設定のアンストールされたものから、残存ファイルを手動で削除し、アクティブな状態にある MDM サーバーの設定を有効な状態で維持します。
    • /var/opt/BESUEM/.env
    • /var/opt/BESUEM/apple
    • /var/opt/BESUEM/mac
  2. 解析構成の検証:

    • macOS デプロイメントでは、.plist.pkg のファイルを /var/opt/BESUEM/packages ディレクトリーから、任意のファイルとファイルを /var/opt/BESUEM/packages/macOS サブディレクトリーに手動でコピーします。
    • 解析 Apple Modern Client Management MDM Servers/var/opt/BESUEM/packages/macOS に正しく適用されるようにします。
  3. 解析更新のチェック:

    • 解析は 15 分ごとに実行されます。正しいディレクトリーにファイルを配置したら、WebUI が更新されるまで、最大 15 分間待機します。
  4. WebUI キャッシュの確認:

    1. MDM サーバーで BESClient を再起動し、最新の解析結果を使用します。
    2. WebUI の正常性チェックを確認し、
      https://<webUI Host>/mdm/next/healthcheck
      すべての MDM サーバーが緑色のライトを表示し、関連の解析がアクティブになっていることを確認します。
      正常性解析のチェック
  5. パッケージの事前ステージングを一貫した状態にする
    • BES Agent インストーラーを事前ステージングする場合は、すべての MDM サーバーに一連の BES Agent パッケージが存在するようにします。
    • 特に複数のサーバーが関与している場合には、すべての MDM サーバーの正しい、最新の分析結果を WebUI が使用していることを確認します。
Note: 上記は一時的な修正です。永続的なソリューションとしては、拡張解析を使った、BESUEM コンテンツのアップデートがまもなく公開されます。