インターネットに接続されていない Android Kiosk

このセクションでは、Android Kiosk の Wi-Fi 接続での問題をトラブルシューティングする方法が書かれています。

問題

Android Kiosk がインターネットに接続されていない。デバイス・ユーザーは、Kiosk モードによる制限があるため、Wi-Fi 設定を変更できない。

原因

Android デバイスが Kiosk モードでアプリを起動しており、登録ポリシーに構成されている Wi-Fi ネットワークが利用できない場合、デバイスは Wi-Fi ネットワークに接続されません。

解決策

IT 管理者は、登録ポリシーを構成することによって、デバイス・ユーザーが一時的に利用可能なネットワークに接続し、アクティブに設定することで、Wi-Fi 構成をリフレッシュできるようにすることができます。

Note: 一時的な Wi-Fi 接続は、アクティブに構成された Wi-Fi 構成の詳細情報を使用して最新のポリシーを取得するためにのみ使用されます。最新の Wi-Fi 構成ポリシーが適用されると、Kiosk デバイスは、ポリシーの指定どおりにネットワークに自動接続されます。

これを行うには、次の手順を実行します。

  1. 設定 "networkEscapeHatchEnabled": true が、専用のデバイス登録ポリシーに構成されているかどうかを確認します。起動後にネットワーク接続に障害が発生した場合、90 秒以内に、この設定を通じて、ユーザーは使用可能なネットワークに一時的に接続してデバイス・ポリシーを更新するように促されます。
  2. デバイスが永続的なネットワーク接続を行うには、Wi-Fi 構成ポリシーにアクティブな Wi-Fi 情報を追加します。

    Wi-Fi 構成ポリシーの例:

    "openNetworkConfiguration": {
      "NetworkConfigurations": [{
        "GUID": "a",
        "Name": "Example A",
        "Type": "WiFi",
        "WiFi": {
          "SSID": "NetworkID",
          "Security": "WEP-PSK",
          "Passphrase": "1234567890"
          "AutoConnect": true
        }
      }]
    }
  3. デバイスが Wi-Fi ネットワークに自動的に接続されない場合は、Kiosk デバイスを再起動し、1~2 分待ちます。新しい Wi-Fi 設定ポリシーで定義されているように、デバイスが Wi-Fi ネットワークに接続されます。